Blog

10.5 Support is ending

Due to the effective end-of-life for Mac OS X 10.5 (Leopard) we will not be supporting it in new major versions of software.
SQLEditor 2.0 will require a minimum of OS X 10.6.8 (Snow Leopard), with 10.8 strongly recommended.

Note that 10.5 will continue to be supported for SQLEditor 1.7.x, however 1.7.x will reach end-of-life when 2.0 is released.

 


 

I am personally sad to see this because this is also the end of the PowerPC support (10.6 is Intel only). Unfortunately it is becoming increasingly difficult to support old versions of OS X and the problem is, if anything, accelerating. The future is coming, and faster than ever.

In particular the difficulty of supporting new features in the latest operating system (currently Mountain Lion), while still supporting old operating systems, is very great. A lot of work went in to getting SQLEditor 1.7.18 correctly signed for gatekeeper on 10.8, because the default Apple signing tools generate signatures that are, in effect, broken on earlier systems. It was almost getting to the point where two versions would have been made available, one for 10.7 and below, the other for 10.8.¬†Fortunately that didn’t happen, but it was pretty close.

In addition the declining proportion of users who use old systems mean that the work increases as the number of customers who benefit declines. And of course, as soon as a user replaces their machine with a new one, they have upgraded and the number of customers benefiting declines again.

Regrettably this makes the correct decision quite clear.

Goodbye Leopard, you served us all well.

Angus

 

 

If you have any questions about this or anything else please get in touch at support@malcolmhardie.com

 

 

Comments are closed.