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Introduction
SQLEditor For Mac OS X is a program to help you work with databases. Relational databases are the
main type of database that SQLEditor supports, however other types can also be used.
SQLEditor allows you to create, import, view, edit and export database structures. You can use it to
create diagrams of databases showing the logical layout of objects within the database. You can save
images of databases to use on webpages or in documents. You can also import and view the structure
of live databases via JDBC
ĳis guide describes SQLEditor 2.0 which is the secondmajor release version for SQLEditor. It differs in
someways from version 1.0, but if you’re familar with earlier versionsmost things should be fairly similar.

! SQLEditor is a powerful tool that allows you to do lots of things. However like any tool
it is possible to do bad things as well as good. Please take care when using SQLEditor,
because incorrect operation may cause serious damage to your database and the data
contained in it.
Make sure you have lots of backups of your database and it’s data; andplease don’t ignore
the warnings in this manual and in SQLEditor itself.
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What's new in SQLEditor 2.0
Multiple Selection and editing
SQLEditor now supports selecting and editing multiple objects at the same time. You can now select
several tables and change schema or table type, or select multiple Ņelds and set them all to be unique
or of type VARCHAR(255)
Mult-object selection and editing only works if you select objects of the same type (for example, 3
tables). If you select objects of differing types (for example 1 table, a comment and a Ņeld) then you
will see the ”Multiple Selection” inspector instead.
Note also that connectors cannot currently be edited using this feature, however you can select the
source foreign key or source Ņeld and edit most of the seśings there instead

Diff Support
SQLEditor now includes diff support, this feature takes two documents or two revisions of the same
document and generates SQL instructions to change the Ņrst revision to the second
For example if document1 contains 1 table ”tableA” and document2 contains 2 tables ”tableA” and
tableB, then thediff featurewill identify that document2 ismissing tableB andgenerateonly the required
instructions to add that table

Tree View
ĳe tree view is a new way of looking at your document in a hierarchical tree. You can edit and select
objects just as in the canvas

Labels Panel
ĳe labels panel allows you to group objects together easily using labels, you can also hide and show
objects by label and move tables easily from one label grouping to another.

Works without Java
SQLEditor will now run on machines that don’t have Java installed. You do still need Java to using
database connection features, but otherwise you can edit, import and export documents without
installing it.

Command Line Interface
SQLEditor now has a command line mode, you can use this to import and export databases to and from
SQLEditor documents, or import and export SQL to SQLEditor documents.
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System Requirements

Minimum System Version

To use SQLEditor at all you will need:

• An Apple Mac Computer running Mac OS X 10.6.8 or later
• Mac OS X 10.7 or later recommended
• Some optional components or plugins may have higher system requirements,

you should read the documentation to find out what these requirements are.
• SQLEditor supports 64 bit mode

Java is normally required to access databases with SQLEditor, for 10.7 and later
you may need to install a suitable Java Runtime.

Database Drivers

SQLEditor connects to a particular database system using a small piece of software
called a driver. If you want to use the database import and export functions in
SQLEditor then you will need the correct driver for your database.

SQLEditor uses JDBC drivers to connect to databases. Other types of
driver are not currently supported.

Please see the chapter on database drivers on page 38 for more details.
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Installing SQLEditor

SQLEditor is distributed either as a compressed ZIP format archive, as a down-
loadable DMG format disk image or on physical media like an optical disk or a
USB stick.

Installing from a compressed ZIP archive

If you have downloaded the SQLEditor ZIP archive from our website you should
follow these instructions to install the application.

1 Locate the downloaded ZIP archive on your computer

2 double click the archive zip file to open it

3 If you see a security message asking you if you want to open the zip file confirm
that the disk image is the correct one that was downloaded, then click continue

4 e archive should decompress and the SQLEditor.app application will
appear next to the archive

5 Drag the SQLEditor application to the Applications folder on your Mac.

Installing from a downloadable disk image

If you have downloaded the SQLEditor disk image from our website you should
follow these instructions to install the application.

4 |



Installing SQLEditor

1 Locate the disk image on your computer

2 double click the disk image to open it

3 If you see a security message asking you if you want to open the disk image

4 confirm that the disk image is the correct one that was downloaded

5 click continue

6 Drag the SQLEditor application from the install disk window to the Appli-
cations folder on your Mac.

Installing from a physical CD-ROM

If you have a physical CD-ROM containing SQLEditor you should follow these
instructions to install the application.

1 Insert the CD-ROM into your computer

2 Drag the SQLEditor application from the install disk window to the Appli-
cations folder on your Mac.

Where to Install SQLEditor

We recommend placing SQLEditor in the /Applications folder. But you can use any
other folder if you prefer. You can also move it after installation if you want to.
When you use SQLEditor it will create preference and settings files in the following
locations.

• ~/Library/Application/Support/SQLEditor/
• ~/Library/Preferences/

On 10.6.8 the following locations may also be used:

• /Library/Application Support/SQLEditor/
• /Library/Preferences/
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Uninstalling

Uninstalling

To uninstall SQLEditor you should drag the application icon to the trash.
is is normally sufficient, however the following files and directories are used by
SQLEditor, so you may wish to delete them too

• /Applications/SQLEditor.app (e application itself )
• ~/Library/Application/Support/SQLEditor/
• ~/Library/Preferences/com.malcolmhardie.sqleditor.cocoa.plist

On 10.6.8 the following locations may also be used:

• /Library/Application Support/SQLEditor/
• /Library/Preferences/com.malcolmhardie.sqleditor.cocoa.plist

ere may also be entries in your keychain for the databases that you access. You
may wish to keep these if other applications are using them too.

Automatic updating

When you first start SQLEditor you will be offered the option to use the automatic
update feature. is uses the Sparkle update framework1.
Automatic update can also be enabled or disabled from the Preferences Window.
If you enable automatic updates then SQLEditor will check our website to see if a
new version is available.
If an update is available then a window will appear on your screen offering the option
to upgrade to the new version. e updated version will be downloaded and installed.
If you don’t wish to upgrade to the new version at all then you should select the Skip
This Version button. You will not be prompted to upgrade to the specified version
again unless you choose SQLEditor→Check for Upgrades....
If you want to upgrade at a later time then you can click the Remind Me Later button
and the update notice will appear on the next restart of SQLEditor.
ere is also an option to send some profile information about your system when
you check for updates. is is used for market research to identify which versions

1http://sparkle.andymatuschak.org/
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Installing SQLEditor

are in use and what types of environment SQLEditor is running in. You can disable
this option in the preferences window.

Other than the system profile information (if enabled) we don’t deliber-
ately collect personal data about you or your mac, however just sending
a request will identify you by IP address and other data may, in theory,
be sufficient to identify you if you have a unique configuration.
If you don’t want this to happen then please don’t use automatic
updates.
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Tutorial: Creating a simple
database design

In this tutorial we will introduce SQLEditor, explain how to create a simple database
design and then export it to a SQL text file for later use.
In our simple example we are going to create a simple database representing a library.
e library will keep records of books and borrowers.

Creating a new Document

1 e first step is to open the SQLEditor application. You should see a new
untitled document window appear on your screen.

2 If you don’t see a new document window use File→New

e document window is where you view and edit your design.
You should also see the inspector window on the right side of the new document
window.

Adding a new Table

1 Click the Add Table button on the toolbar

A new Table object will appear in the window and the inspector will change to show
information about this new table.
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Tutorial: Creating a simple database design

Main Window Inspector

Figure 1: e Document Window and the Inspector
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Renaming the Table

Most likely the new table will be called Table1. But we’re going to change it to be
books.
You can move the table around by dragging the colored title bar

Renaming the Table

1 Make sure the table is selected by clicking once on the colored title bar at the
top of the table.

2 en move to the inspector and click once in the Name: field where it says
Table1.

3 Edit the name of the table to read books

4 When you’ve finished editing the name hit the return key.

5 In the main window the table’s name will change.

Adding a Ņeld to the table

Next we’re going to add some fields to this table. Fields normally have the name id
when created. Fields have to have unique names so SQLEditor will automatically
rename fields by adding a number (id_1, id_2, id_3, etc)

1 Select the books table by clicking on the colored title bar at the top

2 Click the Add Field button in the toolbar

3 A new field will appear in the table

4 Click on the field to select it

5 en move to the inspector on click once in the Name: field where it says id.

6 rename the field to book_id

7 e look at the Type: popup box. Select the type INTEGER from the popup.
(It may already be selected)

Make one of the Ņelds into a primary key

e book_id field is going to used as the primary key for the books table.
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Tutorial: Creating a simple database design

1 Click on the book_id field in the books table to select it.

2 Look at the inspector, at the bottom is a tabbed panel. Make sure the tab
Options is visible. Click the tab if it isn’t visible

3 Look for the checkbox Primary Key and check it

In the main window a P icon will appear on the field. is indicates that it is used
as a primary key.

Create more Ņelds

1 Add fields to the table in the same way until it looks like this

Enter the numerical size of the field type into the size/members field in
the inspector window.

Create more tables

1 Now create another table for the borrowers

2 en create a third table for loans, this table will link the borrowers to the
books

3 Your diagram should look something like this
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Create more tables

Don’t worry if your tables aren’t laid out exactly like this, the exact layout isn’t
important, as long as you can see all of the tables easily. Remember that you can
drag the tables around by the colored titlebar if you want to rearrange them.
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Tutorial: Creating a simple database design

Making foreign key relations

e next step is to link the tables together with foreign key relationships.

1 Look for the tables books and loans. Move them until they are both visible
and do not overlap.

2 Using the mouse drag from the book_id field in the loans table to the book_id
in the books table. As soon as you start dragging a line will appear.

3 When you reach the books table release the mouse. e line should remain
visible between the two fields

4 If the line disappears when you release the mouse, try again and make sure
you don’t release the mouse until you pointer is directly over the target field

5 5 You should see a icon F appear on the loans(book_id) field. is indicates
that it is a foreign key and references another field elsewhere.

6 Next make a foreign key relationship between loans(borrow_id) and bor-

rower(borrower_id)
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Exporting to SQL

Your diagram should now look like this:

Exporting to SQL

1 Choose File→Export to File ...

2 In the save panel that appears choose a file name (for example database.sql).

3 Click Save

e file extension will normally be .sql

SQLEditor associates itself with the .sql file extension, so you may need
to open the saved file from within your text editor.

If you open the file using Text Edit (or your favourite text editor) you can then see
the contents should look something like this:

/* SQLEditor (Generic SQL)*/

CREATE TABLE 'books'
(
'book_id' INTEGER,
'title' VARCHAR(255),
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Tutorial: Creating a simple database design

'author' VARCHAR(255),
PRIMARY KEY ('book_id')
);

CREATE TABLE 'borrower'
(
'borrower_id' INTEGER,
'surname' INTEGER,
'firstname' INTEGER,
PRIMARY KEY ('borrower_id')
);

CREATE TABLE 'loans'
(
'loan_id' INTEGER,
'book_id' INTEGER,
'borrower_id' INTEGER,
PRIMARY KEY ('loan_id')
);

ALTER TABLE 'loans' ADD FOREIGN KEY ('book_id')
REFERENCES 'books'('book_id');

ALTER TABLE 'loans' ADD FOREIGN KEY ('borrower_id')
REFERENCES 'borrower'('borrower_id');
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Common Tasks

is section gives step-by-step instructions to perform some of the more frequently
performed tasks in SQLEditor.
You may also wish to see the sections Creating and Editing Objects on page 30 and
Types of Object on page 24

Create a new document

1 Choose File→New

If you want to select the document dialect you can choose
File→Document with Dialect instead

Add a table

1 Choose Object→Add Table

2 e new table will be added to the Canvas and the Inspector will display
information about it.

3 Click on the Name field in the Inspector and give the new table a name.

You can also set other options at this stage

You can also drag a table object from the palette instead of using the
menu.
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Add a Ņeld to a table

1 Click on the table you want.

2 Choose Object→Add Field A new field will be added to the table representing
the SQL table column. e Inspector will display information about the new
column.

3 In the Inspector click on the name field and give the new column a name.

You can also drag a field object from the palette to the table or use the
add field button in the table inspector

Create a foreign key relation

1 Find the two fields that you want to create the relationship between.

2 Drag from the field you want to make a foreign key to the field that you want
to reference.

3 e F icon will appear on the field set to be a foreign key

Create a View

1 Choose Object→Add View

2 e new view will be added to the Canvas and the Inspector will display
information about it.

3 Click on the name field in the Inspector and give the new view a name.

4 click on the view sql in the Inspector then enter the SQL defining the view
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Add a document comment to the document

1 Choose Object→Add comment

2 In the inspector click on the comment input field to enter the text of the
comment.

As well as document comments you can also have comments for specific
tables or fields You add these using the inspector

Export to SQL DDL Schema Text File

SQLEditor can export your database design to SQL Data description language
(Schema Text) in a number of different formats. You should select the export dialect
of SQL that most closely matches the database system that you are using.

1 Identify the database system that you are using. E.g MySQL, Postgres

2 Choose File→Export As SQL

3 Using the popup menu select the export dialect that you wish to use

4 Choose a name for the export file

5 Click the Save button

If you have previously selected a dialect for your document then
SQLEditor should select this automatically in the popup box.
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Export selected objects

If you just want to export a few objects at a time you can use copy and paste.

1 Select the objects you want to export

2 Choose Edit→Copy

3 Paste the objects into another application

What will I get when I use paste in the other application?

• If the other application accepts text then you should get the SQL representa-
tion of the object as text.

• If the other application supports SQLEditor object format then you will get
a representation of the objects.

! e SQLEditor document’s dialect is used when exporting objects in this
way, you cannot change the dialect during the copying process.

Change export SQL dialect

e document dialect is the default dialect of SQL that is used when SQLEditor
exports SQL code. e document dialect is specific to each document and can be
changed at any time using the following procedure.

1 Click the Export Tab

2 Choose File→Document Options

3 Use the Target For SQL popup menu to choose the dialect

4 Click the OK button to close the window. You can also change other SQL
Export settings in this window.
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Import SQL database description from a text Ņle

To import SQL from a file use the following procedure.

1 Choose File→Import from File…

2 Choose the file you want to import

3 Click the Import button

SQLEditor will attempt to import the file that you select.
e Import Status window will appear giving details of any errors that may occur
during import.

Please report any errors!
Reporting parser errors is one of the main ways that the SQL parser is
improved.
You can send them to support@malcolmhardie.com or use the
Help→Send Suggestion menu option

Set the default SQL dialect for new documents

When SQLEditor creates a new document the dialect for the document is set to the
Default Dialect
You can change this Default Dialect using the following procedure:

1 Choose SQLEditor→Preferences...

2 Select the Export tab in the Preferences window

3 Change the popup menu to the dialect that you want to use

All future documents will now be created with this dialect
You can specify the dialect of a document by using the File→New
Document with Dialect command
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Types of Object

SQLEditor supports a number of different types of objects. Additional object types
may appear in future versions.
It is also possible for plugins to add new object types. You will need to refer the
documentation that came with the plugin to find out how such objects might work.
Some objects in SQLEditor can only be used when contained within another object.
Fields, Indexes and Constraints can only be added to Table objects for example.
e diagrams in this section are taken from the current release of SQLEditor and
use the default appearance.
If you are using have altered the display or appearance settings, or if you are using a
different version of SQLEditor, then the appearance may differ.
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Types of Object

Tables

Table name

Table Comment Available

Figure 2: An example table

e table object represents a table in a database. Tables can have various properties
that can be edited using the inspector or by direct editing Tables can be assigned to
a category, which may be identified by a color. To edit a table (or any object) using
direct editing hit the return key and the table name will become editable.
You can add different types of objects to tables. ese include fields, indexes and
constraints. Other types of object may be added in future versions of SQLEditor.
Figure 2 shows a sample table without any fields.
ere is an option to make tables resize automatically to fit the objects that they
contained. is option is View→Auto Size Tables
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Fields

Fields

Fields in SQLEditor represent columns within database tables. Fields have proper-
ties that can be edited using the inspector. ey can also be moved between tables
by dragging. Fields are always contained within tables except when being moved.

You can also change the data type and some other settings of a field by
using the context menu (Right Mouse Button/Control Click)

Fields support direct editing of the field name.
Columns in databases can have various options and SQLEditor supports most of
the common options. Icons appear on fields for each option that is set.
Figure 3 on page 27 shows the table from Figure 2 on page 25 which has had a field
added it to it.
e field shows all of the possible icons that fields can currently have in SQLEditor.
Most fields will not display all of these icons.
You can also add comments for tables and columns

Field Options

Option Icon Description
Primary Key P e field is part of a primary key
Foreign Key F Field is a foreign key and references another field
Auto Increment A Field has an auto incrementing value (in supported databases)
Not Null N e field cannot be Null
Default Value D e field has a default value set
Field Comment ? e field has an attached comment
Indexed I e field is indexed
Zero Fill Z e field is has the Zero Fill option set (for MySQL)
Unsigned +/- e field is has the unsigned option set (for MySQL)
Unique U e field has a unique constraint set on it
Time Zone tz e field is of type timestamp and has a time zone set.
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Table name

Field name

Field data type
Unsigned

Zero Fill

Unique

Indexed

Primary Key

Default Value Set

Not Null

Auto-increment

Table Comment Available

Foreign Key

Field Comment Available

With Time Zone
for Timestamp

Figure 3: Table and Field layout and icons
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Indexes

Indexes

An index object represents a table index in a database. Indexes allow for specifying
the type of index (normally a database specific value) and the columns that are
included in the index.

Constraints

A constraint object represents a table or column constraint on the database. Cur-
rently only UNIQUE constraints are supported.

! Support for constraints is database specific and somewhat variable

Connectors

Connector objects represent foreign key links between fields and tables. Clicking on
a connector will cause the Inspector window to show the connector inspector panel
which offers options for cardinality, information about source and destination fields
and a button to delete the connector.

Comments

A comment object allows you to include extra information about the diagram.
Comments are exported to SQL along with tables, although they will normally have
no effect on the actual database.
Comments may have different background colors and can have both labels and body
text.

Canvas Areas

A canvas area object is used to visually group together other objects. Canvas area
objects appear behind all other objects. Canvas objects can have labels and extra
information attached to them. e extra information is not displayed (unlike with
comment objects which display both pieces of information)
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Older versions of SQLEditor used special types of comment object instead of a
dedicated canvas area object. To improve compatibility you can convert Comment
objects into Canvas Area objects or vice-versa.

Views

A View object is a SQL database construct that combines different data from
multiple tables together into a single table-like object. Typically a view is specified
using a select statement. In SQLEditor view objects appear much like tables. As
you edit the select statement, the tables and fields that the view references will be
identified and listed in the view object

Compound Foreign Key

e compount foreign key object is primarily used to create compound foreign key
relationships between sets of columns. It can also be used to create simple foreign
key relationships that link only two columns together (however it usually easier to
use the foreign key option on fields directly in this simple case)
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Creating and Editing Objects

is section explains how to create and edit objects in SQLEditor. SQLEditor tries
to behave as other Mac OS X programs.

Adding objects

ere are several methods of adding objects to a database structure:

• e objects menu contains commands to create all types of object
• e objects can dragged from the objects palette
• e context (right click) menu can be used to create some kinds of object

You can also add extra fields using the Add Sibling in the field inspector, and the add
field button in the table inspector
It is also possible to use a popup menu or copy and paste objects or sql script into
the document.
See also: Adding a table on page 18 and Adding a field on page 19
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Editing Objects

Objects can be selected by clicking on them. Note that selecting a field will also
select the parent table.
When an table or comment object is selected then control handles will appear on all
sides of the object. ese control handles can be used to resize the object. To move
the object the title bar can be dragged or the cursor keys used. Holding down shift
causes the cursor key movement to be faster.

Figure 4: A Selected Field

Field objects do not have control handles, but a drag handle appears when a field
is selected. is drag handle can be used to move or copy a field from one table to
another.
You can copy a field from one table to another by holding down the Option key while
dragging.
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Automatic Renaming

Automatic Renaming

Objects in SQL should normally have unique names. SQLEditor will attempt to
prevent you from creating two objects that have the same name.
Typically this happens as you add new objects or edit the names of existing objects.
e name will change as soon as the object is redrawn.
For example, if there are one table in the document, Table1

A new table is added. It will automatically be given the name Table1_1

Deleting objects

To delete an object either:

• select it and then choose edit→delete
• hit the Delete key on the keyboard.
• right click and choose delete object

32 |



Creating and Editing Objects

Copy and paste

You can use copy and paste on table and comment objects. If you copy an object and
switch to another application then SQL code will be placed on the clipboard. is
is a quick way to export table structures.
If you have sql code in another application you can paste it into SQLEditor and it
will be imported into the current structure using the SQL importer
If the SQL contains an error, or if SQLEditor doesn’t understand it, then the status
window will appear

Dragging and Drop

Most objects in SQLEditor support dragging. Inside the canvas you can move
objects by dragging.
If you hold down the Option key (alt) then you can create a copy, or drag an object
into another application or a different window.

Figure 5: Duplicating a table by option dragging

You can use the objects palette to create new objects on the canvas by
dragging the icon representing the object.

Foreign keys

Currently there are two ways of creating foreign keys in SQLEditor. For simple
column to column relationships it is easiest to link the fields together directly.
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Foreign keys

For more complicated configurations including more than one pair of columns you
should look at adding a foreign key object.

Using Field level foreign keys

With this method foreign keys are created by dragging from one field to another
field. You must ensure that you do not start the drag within the drag handle area
of the field. When the drag is complete release the mouse button and a foreign key
link will be added.

! Not all databases support foreign keys and some only offer limited
support. For example: MySQL requires that you use the INNODB table
type if you want foreign key support.

Foreign key links can be configured to draw in several different styles.
See the Appearance Preferences Section on page 78 for more details

Note that if you create a foreign key relation, the referenced field must
be a unique or primary key.
SQLEditor will automatically set the field to be unique if necessary.

Example

1 In this example we want to create a foreign key on the widget table that
references the primary key of the sprocket table.

2 Create a new field to be the foreign key
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3 Drag from a field on the widget table to the primary key of the sprocket table.

4 e new foreign key relation:
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Foreign keys

Using a Foreign Key Object

For more complicated foreign key relationships you should use a foreign key object.

1 Select the table you want to link from

2 choose Object→Add Foreign key

3 Drag from the newly created foreign key object to the target table to create a
connection.

4 Click on the foreign key to update the inspector window

5 Add a column pair by clicking the [+] button at the bottom of the foreign key
inspector.

6 choose a column for source and target in the column pair.

Entries in foreign key objects need both source and target set or they will
be ignored.
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Databases: Import and Exporting

SQLEditor can import existing database structures into a new document and it can
directly create a database structure from a document.

About Database Drivers

SQLEditor needs a JDBC driver specific to the database that you wish to use.
You may also need to build the database with special options for jdbc compatibility
or set specific options in the configuration of the database.

! SQLEditor doesn’t ship with any JDBC drivers so these must be installed
before use.

Supported Database Drivers

Many database drivers are now automatically detected by SQLEditor and so you
only need to install the jar file. SQLEditor will then find and use the driver on the
next restart.
Currently only JDBC Drivers compatible with java 1.4 will work with SQLEditor.
e following drivers are automatically detected by SQLEditor.

• MySQL
• PostgreSQL
• Oracle
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• SQLite
• OpenBase
• Microsoft SQL Server

Drivers that are not on this list may need be added manually using the Database
pane of the Preferences window. See also Database Preferences on page 79
If the driver you want to use isn’t on this list it is worth seeing if SQLEditor has
auto-detected it before adding it manually.

Installing Database Drivers

General Instructions

1 Download the correct driver

2 Find the .jar driver file in the download package

3 Place the driver file in /Library/Java/Extensions

4 Restart SQLEditor

You only need to perform the following step if the driver is not visible in the
Database Driver List in the Database Preferences pane:

5 Add the database driver to the driver list.

If you prefer you can install drivers in

/Library/Application Support/SQLEditor/JDBC Drivers/

Drivers installed in this location will be available only to SQLEditor. is may
be useful if you intend to run other JDBC applications which require incompatible
drivers.
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MySQL

MySQL

You can download this from
MySQL Connector J Driver Download Page2

How to install MySQL driver

Follow these instructions to install the MySQL JDBC driver.
e file names may vary slightly if you use a different version of the driver.

1 Go to MySQL Connector J Driver Page3

2 Download the file mysql-connector-java-5.1.13.tar.gz (Platform Independent

Architecture Independent, Compressed TAR Archive)

3 Decompress the file by double clicking

4 Locate the JDBC driver jar file mysql-connector-java-5.1.13-bin.jar (inside the
decompressed archive)

5 Copy the jar file mysql-connector-java-5.1.13-bin.jar to /Library/Java/Extensions

6 Restart SQLEditor - SQLEditor should then be able to use the driver
correctly

SQLite

Our SQLEditor SQLite Driver Page4 offers downloads of our recommended driver

• Go to SQLEditor SQLite Driver Page5
• Download the binary release
• Copy the downloaded .jar file to /Library/Java/Extensions

SQLEditor should find this driver automatically

2http://dev.mysql.com/downloads/connector/j/5.0.html
3http://dev.mysql.com/downloads/connector/j/
4http://www.malcolmhardie.com/support/sqleditor/sqlite/index.html
5http://www.malcolmhardie.com/support/sqleditor/sqlite/index.html
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Oracle

e Oracle JDBC drivers can be downloaded from the Oracle JDBC Driver Page6.
e download contains several driver jar files. You will need at least a ojdbc*.jar file
and a orai*.jar. Different configurations of Oracle systems may need different files
We have done much more testing of the 10g driver. e 11i drivers may work, but
only with SQLEditor 1.6 or later.

• Install the JDBC driver in /Library/Java/Extensions

6http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/index.html
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Postgresql

Postgresql

First obtain a suitable driver:

• If you are using the Entropy packages7 by Marc Liyanage then the current
build contains everything you need.

e driver is installed at /usr/local/pgsql/share/java
• If you are using another package then you may need to download the JDBC

driver from the Postgresql JDBC site8

en install the driver:

1 Copy the jdbc driver to /Library/Java/Extensions

2 Edit /usr/local/pgsql/data/postgresql.conf so that tcpip_socket = true is set.
It may be set to false or not be present at all in the default settings

SQLEditor should find this driver automatically

OpenBase

OpenBase uses the URL com.openbase.jdbc.ObDriver.

• Install the JDBC driver in /Library/Java/Extensions

SQLEditor should find this driver automatically

Unsupported Databases

If a database system has a JDBC driver it should work, although databases that use
a java swing or AWT user interface in their JDBC driver will probably not.

7http://www.entropy.ch/software/macosx/postgresql/
8http://jdbc.postgresql.org/
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Making a JDBC Driver available only to SQLEditor

You can place JDBC database drivers in either:

• /Library/Application Support/SQLEditor/JDBC Drivers/ - for use only by SQLEd-
itor only

• /Library/Java/Extensions/ - for use by all programs on your machine

e instructions on this page assume that you will use the /Library/Java/Extensions/
directory.
If you use the SQLEditor specific directory option you will need to subsititute the
correct directory path.
e Database Preferences Pane on page 79 is used

Importing from a database

e File→Import From Database... function will connect to an existing database and
extract the structure, it will then create a new document containing that structure.
See also e Database Import Panel on page 58
SQLEditor doesn’t keep a link between the newly created document and the original
database.
To create a new document from an existing database

1 Choose File→Import From Database...

2 Enter the connection details into the Import Database Panel

3 Click the Import Button

Exporting to a database

e File→Export To Database... function will connect to an existing database and
attempt to modify that database’s structure to match the current document.
e modification of existing databases is somewhat imperfect. Best results are
achieved with an freshly created and empty database as the target.
Exporting to an existing database is likely to cause loss of data.
See also e Database Export Panel on page 60
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Exporting to a database

To export a document design to a database

1 Choose File→Export To Database...

2 Enter the connection details into the Import Database Panel

3 Click the Export Button
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Files: Importing and Exporting

As well as importing and exporting designs to a database, SQLEditor can also
import and export to certain file formats. e main format is SQL data description
language (often called a database dump), but SQLEditor also support RubyOnRails
migration format.
Future versions of SQLEditor may support additional export formats.

Importing from a SQL File

SQLEditor contains a fairly complete SQL parser that can read in text represen-
tations of SQL Databases. Typically you can create these using a database dump
utility.

1 Choose File→Import From File...

2 Select the file you want to import

3 Click Import

A new document will appear containing all of the objects that SQLEditor was able
to read in the file.
If SQLEditor had difficulties reading the file then the Status Panel will appear with
details of the errors.
See also e Status Panel on page 56
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Exporting to a SQL text File

SQLEditor can export a database design to a text file, which is can then be imported
into a database using a suitable tool.
is is useful if you have a database running on a remote server and you cannot use
JDBC to connect to it.

1 Choose File→Export To File...

2 Choose the export dialect that matches the database system that you are using

3 Enter a suitable name for the new file

4 Click Export

A new document will appear containing all of the objects that SQLEditor was able
to read in the file.
If SQLEditor had difficulties reading the file then the Status Panel will appear with
details of the errors.
See also e Status Panel on page 56
e dialect in the export window is preset to match the document dialect

Exporting to a SQL Diff

Sometimes you may have an existing database, but need to make some changes. For
example you might wish to add a column to a table. SQLEditor can help you with
by generating a diff. A diff is a series of SQL instructions that alter the existing
database to a new state.
To generate a diff you will normally need two documents, the first representing the
initial state, the second representing the required state. Both need to be open in
SQLEditor. You cannot currently compare against a document unless it is open, nor
can time-machine or versions documents be used.
SQLEditor also allows you to generate a diff between the current state of a
document and a snapshot of the current document when it was most recently loaded.
SQLEditor automatically creates a snapshot of each document when loaded for
comparison. Note however that if you close a document, any snapshots will be lost.
So if you need to do more than a simple one-off comparison, you should save a copy
of the document first and compare against that.
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Ruby On Rails Export

1 Make sure that both current and initial state documents are open in SQLEd-
itor

2 Choose File→Export diff...

3 Choose the export dialect that matches the database system that you are using

4 Choose the document or snapshot representing the initial state that you want
to generate the diff against.

5 Click Export

Ruby On Rails Export

e Ruby On Rails exporter is not a database export. Instead it is considered a
dialect of SQL, so use the File→Export to File... menu option. (is is because the
Rails exporter exports a text file rather than interacting with the Rails setup directly.

1 Choose File→Export to File...

2 Make sure Rails is selected as the dialect

3 select a location to save the model file

4 Enter a suitable name for the new file

5 Click the Save Button

Ruby On Rails Import

You can import Ruby On Rails migration files using the Import from File option

1 Choose File→Import from File...

2 Choose a file to load

3 Click the Import Button

! e Ruby On Rails importer will execute any file that it imports within
a Ruby interpreter. It applies security limitations, but it is possible that

these limitations may be overcome by malicious code.
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Saving as an Image

You can save an image of the current document in a variety of formats

1 Choose File→Save as Image...

2 Select a format to save the image

3 Click the Save button

See also e Image Export Panel on page 62

Import and Export with the clipboard

SQLEditor also supports importing and exporting SQL via the clipboard.
If you paste SQL code into an SQLEditor document window then SQLEditor will
attempt to parse and import any objects it finds. Errors will appear in the status
panel.
If you copy objects out of SQLEditor and then paste into a text application then
you will get the code for the objects, normally in the current SQL dialect. If you
are using Rails as the default dialect then you will get Rails migration format as the
pasted text.

Note that you cannot paste Rails Migrations into SQLEditor.
You should use File→Import From File... instead

| 49



SQLEditorWindows

ĳe document window

e document window is the main window which contains the database structure.
ere are two main parts to the document window.

• e Canvas. is graphically displays the structure of the database design.
is appears on the right

• e Sidebar. In SQLEditor this section displays different panels related to the
document.

ĳe Sidebar

e sidebar can display several different panels. You can change the currently
displayed panel using the button bar located at the top of the sidebar.

• e SQL source view panel displays the SQL source text of the database design.
Normally it appears on the left although it can be hidden if you prefer.

• e Diff panel displays SQL instructions to change from one version of a
document to another

• e Find panel allows you to search the document for specific objects
• e Tree view panel displays a hierarchical tree view of the document
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Sidebar Canvas

Sidebar mode selector
Main Toolbar

Full Screen Toggle

Sidebar size control

Reload 
Source View 

Current SQL 
Dialect

Figure 6: An empty document window
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Moving around the canvas

e Sidebar may be hidden by dragging or double clicking the Sidebar
Divider Control.
SQLEditor can be configured to hide the Sidebar when creating a new
document. If the sidebar is hidden just double click on the divider control
to open the sidebar.

Moving around the canvas

e canvas can be scrolled using the scroll bars at the right and bottom. ese scroll
bars respond to mouse wheel movements too. You can also scroll by holding down
the Option or Alt key and dragging the canvas using the mouse.
If you customize the document toolbar and add the Tool toolbar button you can use
a special hand tool to move the canvas.

Zooming

You can zoom out the canvas to display more objects simultaneously by using the
zoom control in the toolbar. If you have a multi-touch trackpad you can use the
standard pinch zoom gestures. SQLEditor can zoom down to 5%.

You can also optionally zoom using themouse wheel (although this needs
to be enabled first in the Preferences window)

Print scaling is independent of document zooming. If you set a print
scale factor in the File→Page Setup panel then this will always be used
for printing, regardless of the document zoom level (which is for display
only).

You can have more than one document window open at once. To switch between
different windows either click on the window you want or use the window menu to
choose a different window.
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To learn about how to create and edit objects see Creating and Editing Objects on
page 30.

ĳe InspectorWindow

Figure 7: e Inspector window with a field selected

e inspector window is initally positioned to the right of the document window. If
an object is selected then the inspector will show details of the selected object. Any
changes made will be immediately reflected in the object
With tables, fields, comments, canvas areas and views, SQLEditor allows you to edit
multiple objects at once. Note that you cannot rename groups of objects and that
some types of objects don’t allow multiple editing.
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e Inspector Window

Inspecting Objects

e inspector window will show an inspector panel for the currently selected object.
is inspector panel is different for each kind of object and offers options and setting
specific to that object.
Objects can be locked into position on the canvas by using the Position Locked in
the inspector.

Field Inspector

e field inspector allows editing of fields, which in SQLEditor represent table
columns

Name is is the name of the field. SQLEditor may modify names you enter to
ensure that the eventual SQL output is valid. In particular, you can’t normally have
two columns with the same name. If you try, then SQLEditor will add a number
suffix to the name to ensure that each object is uniquely named

Type is popup menu contains a list of the data types that are supported for the
current dialect. You can also enter your own types here if you wish. If you enter a
type with brackets (e.g VARCHAR(255) then the section within the brackets will
be copied to the size/members field

Size/Members is field is used to specify any parameters of the type. is usually
means length, but might also be precision or decimal places displayed. If the type is
a set type it might include the entries in the set. It’s normally database specific

Default Value e default value for the field. SQLEditor will normally try to
quote values if appropriate, so you don’t need to add quotes. If you want to manually
specify the exact value and any quotes yourself, check the Don’t quote default value
option

Delete Field Delete this field from it’s parent table

Add Field to Table Adds another field to this field’s parent table. Older versions
of SQLEditor call this Add Sibling
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Parent Table e name of the parent table for this field. ere is a small arrow to
the right of the name which, if you click it, will select the parent table and show the
inspector for it

Sub-panel menu e field inspector has more controls than can fit in the window,
so they are divided into sub-panels. e subpanel selector menu allows you to change
which subpanel is displayed

Options Panel

Primary Key Checked if this field should be part of a primary key. Checking this
adds the current field to the table primary key, unchecking it will remove this field
from the primary key. It won’t affect whether other fields are part of the primary
key. (It isn’t an exclusive operation)

Unique Checked if this field should have be UNIQUE. e result of this varies
between databases, in MySQL it will normally export with the UNIQUE keyword,
in other databases it may generate a UNIQUE index
If a field is the referenced target of a foreign key, then it is normally required to be
either UNIQUE or be part of a primary key. SQLEditor will normally enforce this
using UNIQUE, so this option will be checked and grayed out

Auto Increment Checked if this field should have an auto-incremented value when
a row is added. is varys between databases, in MySQL it adds the AutoIncrement
keyword to the export, if the type is appropriate. SQLEditor will normally try not
to add this option to the exported SQL unless it makes sense

Unsigned Checked if this field has a datatype that should be UNSIGNED. is
won’t export anything unless the base data type supports UNSIGNED

Not Null Checked if this field should be declared NOT NULL. If it should be
nullable then it should be unchecked

Zero Fill Checked if the field should be specified Zero Fill. (Mainly for MySQL
use)
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e Object Palette

With Timezone Checked if this field should be a time or date type and should be
specified with a time zone. is will have an effect only if the base data type supports
time zones

Don’t Quote Default Value If checked, the default type will be exported without
adding any quote marks. is allows you to control how the default value is quoted
without SQLEditor making changes. If it is unchecked then SQLEditor will quote
the default value as appropriate and escape any quote marks that you include.

Indexed Checked if this field should be indexed. is normally causes a new index
to be added to the table at export. (Note that this index is only seen at export, it won’t
add an index to the parent table in SQLEditor)

prefix size Allows you specify the size of the index prefix. An index prefix limits
the size of an index to improve performance

ĳeObject Paleśe

e object palette contains simple template objects that can be dragged to the
document window.
Typically there are object templates for the three basic object types (tables, comments
and fields/columns). To use a template object simply drag it to the document
window’s canvas. When this happens a new object will be created as close to the
template as possible. e object name may be slightly altered depending on the
objects currently in the document. Two objects in a document cannot have the same
name, so SQLEditor will slightly rename the second object (usually be appending a
number to the name).

ĳe Status Panel

The Status Panel appears when SQLEditor wants to report something.
e Status Panel displays messages for each action. Actions can also include buttons
to allow you to see more information.
Click the Clear button to remove the current messages from the status panel.
SQLEditor logs what it does when performing some actions. Click the Show Log
button on the relevant item to see more information.
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Figure 8: e Object Palette

Figure 9: e Status Panel

e actions that can cause the Status Panel to appear include

• Import From File ...
• Import From Database ...
• Export To Database ...
• Paste (When pasting SQL directly into a document)

ĳe Find Panel

Note that in SQLEditor 2.0, the find panel has been replaced by the Find sidebar
panel in the document window on page 50
Choose Edit→Find→Find… or click the Find tab in the sidebar
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e Database Import Panel

ĳeDatabase Import Panel

Figure 10: e Database Import Panel

is panel is used to import database designs from a database.
e import panel is fairly similar to the Database Export Panel on page 60.

Presets

e presets menu is used to store groups of connection settings for future use. To
do this you should enter all of the details for a connection and then choose Add New
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Connection... from the Preset menu. A new entry will then be created in the Preset
Menu

Driver

e driver popup allows you to choose which database driver you want to use to
connect to the database. ese need to be installed in a specific location.

Host

e host field specifes the computer that the database software is running on. use
localhost if the database is running on the same machine as SQLEditor.

Database

Enter the name of the database into this field.

Port

If your database is running on a non-standard port (or you think the number that
SQLEditor provides is wrong) then you can provide a different port number in this
box.

Schema

If you are using schemas in your database then you can limit the import by entering
a particular schema’s name into this field

User Name

Enter the username into this field

Password

Enter the password into this field
SQLEditor stores usernames and passwords in the keychain for better security, so
you may be asked to enter your keychain password
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e Database Export Panel

Use SSL

Some databases support secure connections using SSL, if this is a supported option
for the driver then this box will be enabled.

Use Self Signed CertiŅcates

If you enable secure connections but are using a self signed certificate this option
relaxes some security checking to allow the connection to work.

Url

e connection string that SQLEditor will use appears here. If you wish you can
alter the connection string and SQLEditor will use your string instead.

Table Filter

If you want to import only some tables then you can enter a search string into this
box. A simple substitution will occur and any tables which have names matching
the string will be imported. Tables that don’t match will not be imported.

Import

e import button starts the import process. SQLEditor will create a new document
and display a progress bar. When it has received the necessary information from the
database it will display the new objects in the document window.

ĳeDatabase Export Panel

is panel is used to export database designs to supported databases.
e export panel is fairly similar to the Database Import Panel on page 58
e Export panel has most of the options that the Import Panel has, except that the
Table Filter field is replaced with the Remove tables not in current Document

Remove tables not in current Document

When selected this option causes SQLEditor to remove any tables from the database
that are not in the document being exported.
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Figure 11: e Database Export Panel

Normally SQLEditor does not delete tables from the database. However any
database operation that modifies the structure is potentially harmful and care should
be taken.

Simulate Export

Selecting this option will make SQLEditor inspect the existing database and
generate instructions to update it. However no updating instructions will actually
be sent to the database. You can view the instructions that would have been sent in
the Status Panel.
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e Image Export Panel

See also e Status Panel on page 56

ĳe Image Export Panel

Figure 12: e Image Export Panel

is panel is used to export documents as image files.
See also Saving as an Image on page 49

Image Format

Choose the image format you want from the popup list.

ĳeDocument Options Panel

is panel is used to edit document level settings
It currently has two tabs, Export and Printing
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Export

is tab includes some options relating to SQL export for the document

Target for SQL

is is the dialect that is used to generate SQL in the source sidebar and the default
dialect for exporting
It is not used when exporting to JDBC (the correct dialect for the database will
normally be used instead)

You can also change this setting using the menu at the top of the source
sidebar

Drop table before create

is option causes SQLEditor to drop all tables at the beginning of an export. It
may make table creation more reliable

! If you check this box then existing tables will be deleted

Add SQLEditor seśings table

is option (if available) causes SQLEditor to create an extra table to store document
settings and object location iwthin the exported SQL. It is normally unavailable and
unchecked.

Printing

is tab includes some options relating to document printing

Header

is box allows you to set the header text that appears on the page when printing a
document
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e Labels Panel

Footer

is box allows you to set the footer text that appears on the page when printing a
document

ĳe Labels Panel

label 
color

Label Visibility table count

Hide All Labels

Show All Labels

Expand/Collapse 
Table list

Add new label

Table Object 
(drawn in gray)

Label
 (drawn in black)

Figure 13: e Labels Panel

Labels are used to group together sets of related objects. All of the objects with a
specific label will color coded with the label’s color. e Default Label appears at the
top of the list and contains any object not associated with another label. e default
label can be shown and hidden, and you can change the color, however you cannot
rename it, nor can it be deleted.
In SQLEditor 2.0, labels are a way to logically group tables together in a document.
ey don’t affect the output, so you’re free to arrange them for your convenience
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e labels panel allows you to rename labels, change the label color, move tables
from one label to another (as an alternative to using the inspector).
You can also change the visibility of all of the objects in a label group in one action
using the visibility control
e label panel has four columns: visibility, name, table count and color:

• e visibility column shows whether the label (and all of its tables) is visible
or not. Clicking the icon changes the label between visible (open eye) and
hidden (closed eye), to change it back click the icon again

• e name column displays the name of the label, this can be edited by double
clicking it.

• e table count column displays the number of tables that are associated with
the label, there is also a disclosure triangle button to expand the label and
display the associated tables

• e label color column allows you to change the tint color for the label.
Clicking on the color will display a standard color chooser

At the bottom of the window are controls to to add a new label and to hide and
show all the labels in the document. To remove a label from the document, use the
context/right click menu and choose Remove Label. If you remove a label then all of
the tables associated with it are transfered back to the default label.
See also e Inspector on page 53
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Preferences

e preferences window allows you modify the way that SQLEditor behaves It
preferences are arranged into sections and each section is displayed on a separate
tab.
Choose Preferences→SQLEditor to display the Preferences Window

e preferences window contains multiple tabs, change tabs by clicking the icons at
the top of the window

General Preferences

e General preferences Tab displays preferences that don’t fit one of the other
categories.

Open New Document at launch

Normally SQLEditor will create a new untitled document when it starts up. If you
uncheck this option then this doesn’t happen.
For example if you normally always start by importing a file or if you only working
on existing documents then you may wish to change this option.

Show Data Loss warning for database export

is option allows you to disable the warning that appears when SQLEditor thinks
a database export operation may cause tables to be deleted
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Figure 14: e General Preferences Tab

Disabling this warning means that SQLEditor will delete tables in your database
without telling you first. Make sure you have backups.

Use Scroll wheel for Zoom

is option allows you to use the scroll wheel on your mouse to zoom in and out on
the document window.

Use command+scroll zoom

is option allows you to zoom the canvas by holding the command key and moving
the mouse wheel.

Check for updates automatically

If enabled then SQLEditor will check at intervals to see if a newer version is available.
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General Preferences

Check for beta versions Allow the automatic updater to download pre-release beta
versions as well as stable releases.
If you are running a beta version then you cannot uncheck the Check For beta versions
option (because you are already on a beta version)

Send configuration information If enabled, SQLEditor will send a snapshot of
your current Mac configuration for statistical purposes. is will not contain any
identifiable information. e information will contain information such as the
current Mac OS X version, the amount of memory you have and the current version
of SQLEditor in use. We use this information to determine where to focus our
development efforts

Force foreign key type matching

is option makes SQLEditor change the data type of a field with a foreign key
relation so that it matches the type of the referenced field.
It is disabled by default

Save connector position

Normally SQLEditor will save the position of orthagonal connectors if they have
beenmanually moved. If you would prefer that this didn’t happen disable this option.

Create simple foreign key links when possible

SQLEditor offers two types of foreign keys, either simple connections from one
field to another or foreign key field objects which allow multiple fields to be linked
together.
Enabling this option causes SQLEditor to generate the simple style references
whenever possible, only using the foreign key object when specifically required.
is option only applies when SQLEditor creates a foreign key object, you can always
create both types of foreign key by hand if you wish

Use OS X Autosave and Versioning

If this option is enabled then SQLEditor will autosave documents and supporting
versioning in OS X 10.7/Lion and later. Documents may be automatically saved at

any time and all changes are tracked.
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Disabling this option makes SQLEditor behave in the traditional OS X style,
documents are saved only when you choose
You must restart to see changes to this setting.

Auto save documents

Auto save a backup of the current document at intervals. is option is incompatible
with the Autosave and Versions support.

Defaults Preferences

e options on the Defaults preference tab change the settings that are used by new
documents. e options match those available in the View menu
See also e View Menu on page 89

Figure 15: e Defaults Preferences Tab
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Defaults Preferences

Show Page Grid

Draws a grid behind the objects for alignment purposes

Snap to Grid

e position of objects will be aligned (or snapped) to the intersections of the grid

Show Page Boundaries

Display lines showing approximate edges of printed pages if the document were
printed using current settings

Show Source Sidebar

is option causes SQLEditor to make the source sidebar visible when a new
document is opened.
If this option is disabled, the source sidebar can still be made visible after the
document has been created.

Show Field Types

Display field types (e.g. VARCHAR, INT) in tables when displayed. is only
affects display of the fields, the underlying types are still specified.
is option is mainly to simply display of complicated diagrams where the simplicity
of not displaying types is traded off against the total amount of information displayed

Show Field Icons

Display icons for field information (e.g. P for PRIMARYKEY,U for UNSIGNED,
etc) is only affects display, the underlying data is unaffected
is option is mainly to simply display of complicated diagrams where the simplicity
of not displaying field icons is traded off against the total amount of information
displayed

Auto size tables

SQLEditor will resize tables so that the whole width of the name and all of the
content in the fields contained in the table are visible
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PreŅx index name with table name

When creating a new index, add the name of the table to the new index name
is helps to create indexes with unique names

Set indexed on Ņelds where possible

If enabled, when importing, SQLEditor will try to set the indexed property on fields
rather than creating a new index object in the table.

Foreign Key Cardinality

is option specifies the default cardinality settings for newly created foreign keys
that are manually created by you

Default Import Cardinality

is option specifies the default cardinality settings for newly created foreign keys
that are created by SQLEditor when it imports a foreign key from a database or via
the SQL parser

SQL Export Panel

Default SQLDialect is popup menu allows you change the SQL dialect that is
used for new untitled documents.

Use Go for sybase Export is option allows you to choose whether you want to
include ”GO” statements when using the Sybase Dialect.

Quote Identifiers on Export is option specifies whether object identifers (field
names, table names, etc) are quoted in exported SQL.
is is normally a good idea because it means you have more freedom in the names
that you use for objects.

Automatically quoted identifiers with whitespace is option specifies whether
objects with whitespace in them (e.g ”Hello World”) are automatically quoted.
is is normally a good idea because it means you have more freedom in the names
that you use for objects.
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SQL Export Panel

Figure 16: SQL Export Preferences

Include Exporter Name Comment in export is option specifies whether you
want the exported SQL to contain a short comment at the top of the file indicating
which dialect was used to export it. is is normally useful to readers of the file and
has no side effects, but disabling it has no effect either.

Prefix index nameswith table name is causes index names to modified on export
so that they are prefixed with the name of the table they refer to. is reduces name
conflicts, however if you prefer to handle this yourself then disable the option.

Use ”IF NOT EXISTS” where Possible Use the IF NOT EXISTS form of the
create table instruction if this is possible
Some database dialects offer the option to create tables only if they do not currently
exist. is prevents errors if the table already exists. However it also means that if
the table does already exist then you may end up with a database that contains an
old version of the table that isn’t replaced.
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e default export settings are chosen to reduce the likelihood of export errors.
Changing these settings may cause exporting to fail.

Rails Migration Export Panel

Figure 17: Ruby Migration Export Preferences

Migration file name is option allows you to choose the default file name when
exporting rails migrations. is is the file name that appears in the save sheet before
you edit it. You always have final control over the file name of the migration.

• Name only is option gives you a default file name that consists of the
document file name modified to meet Ruby class naming requirements

• Timestamp andName is option gives you a Rails 2.x style timestamp and
file name default. e.g 20100101_file.rb
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Datatypes

• DefaultRevision andName is option gives you the default revision (initally
1) and a valid file name. e.g 1_file.rb

Rename underscores with Rails Export is option causes underscores in table
names to be removed during export.

Datatypes

Figure 18: e Data Types Preferences Tab

e DataTypes pane is used to manage data types for different dialects.
eDataTypes pane displays one dialect at a time. To choose which dialect to display
use the popup menu Dialect at the top of the pane.
When you select a dialect the datatypes for that dialect appear in the left hand list.

You can delete types by clicking the - button at the bottom of the list.
To add a new type enter the type into the Add Type box and click the Add button.
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To set the default type for the dialect choose it from the popup menu. A mark will
appear in the list to the left of the default type indicating this.

Automatically add new types as used

If this is enabled then SQLEditor will automatically add new types to the document
dialect when you use them for fields.

Reset All Dialects

is button resets all of the dialects back to the configuration that was supplied with
SQLEditor.
Reset All Dialects will permanently remove all of your modifications to the dialect
types.
Please be careful!

Appearance Preferences

e appearance pane is used to set options for object appearance.

Draw Field Borders

is option sets whether SQLEditor will draw lines between fields in tables.

Always show Drag Handle

is option specifies whether the drag handle on field objects should remain visible
at all times. If it is disabled then the handle will be visible only when the field is
selected.

Draw Rounded Boxes

is option switches between the newer drawing style that uses round boxes and the
original SQLEidotr drawing style that uses square boxes.

Use new style color box headers

By default SQLEditor uses changes the color of the table header to represent labels.
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Appearance Preferences

Figure 19: e Appearance Preferences Tab

If you deselect this option then SQLEditor will color the background of the table
instead.

Align Field Types in Column

is option indicates whether SQLEditor should align field type labels in a vertical
column or draw the labels immediately after the field name.

Beśer highlighting of dark objects

Uses an asthetically better, but slower algorithm when drawing highlighted objects.
is improves the appearance of objects that have darker backgrounds.

Snap to bośom right on grid

If snap to grid is enabled and this option is also enabled then objects will be snapped
to both top left and bottom right on the grid, increasing size if necessary. is means
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that all objects will be sized to a multiple of the grid size.

Object Handle Size

is allows you to change the size of the draw handles that appear when seleecting,
moving and reszing objects.

Grid Size

is allows you to change the size of the background grid that appears when you
select View→Show Grid and which is used for alignment purposes with View→Snap
to grid

Object Color Preferences

Figure 20: Appearance Color Options Tab
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Connector Style Preferences

is section allows you to change the colors of the various display objects. Click the
color well to change the color of the specified object

Reset Colors is button resets the colors to the original defaults, clearing any
changes you have made

Connector Style Preferences

Figure 21: Appearance Connector Options Tab

On this pane you can choose which style you want SQLEditor to use to draw
connectors.
e orthogonal style is the only one that allows you to manually change the position
of the connectors.
e vertical connector style will draw a connector attached to the top or bottom of
a table (as appropriate)
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Database Preferences

Figure 22: e Database Preferences Tab

e database pane is used to manage database drivers for JDBC Export.
e main section of this pane is taken up with a list of installed database drivers.
All of the database drivers listed will appear when you choose File→Import From
Database... or File→Export To Database....

Adding a new Database Driver

If the database you wish to use has a JDBC driver, but that driver is not currently
listed in the window then it may be necessary to add it manually.

1 Click the Button marked with a + icon.

2 Enter the details of the new driver in the sheet that appears

3 Click OK
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JDBC Driver Preferences

Open Driver Directory

is will open the JDBC Driver installation directory in the Finder

JDBC Driver Preferences

Figure 23: e JDBC Options Preferences Tab

Use login timeout

Ask the JDBC driver to timeout if it fails to connect within a time limit
Only some databases support this option, but if the server is down or the connection
fails, this will display the error faster. In exceptional circumstances this may cause
the connection to be cancelled before the server responds, but if the connection is
that slow it probably isn’t usable anyway
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Save non-preset connection passwords

is option makes SQLEditor save passwords that you enter into the database
connection window even if you don’t specifically save them to a preset connection.
Connections saved to a preset will normally always save the password
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Menus

SQLEditor Menu

e SQLEditor Menu contains commands to control the application with respect
to the rest of the system.

About SQLEditor

Shows the about box which contains the application version number, the serial
number and username of the registered user and the expiry date (if applicable)

Check For Updates

Checks the SQLEditor website to see if an updated version is available and can
automatically upgrade SQLEditor if you choose

Registration

Allows you to enter your username and serial code to register SQLEditor and disable
the nag screen at startup

File Menu

New

Creates a new untitled document using the default dialect
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New with Dialect...

Creates a new untitled document, offering a choice of dialect

Open...

Open an existing SQLEditor file

Open recent

A submenu offering recently used documents

Import From File

Create a new document by importing from an existing SQL text file
See also: Importing from a SQL file on page 46

Import From Database

See also: Importing from a Database on page 43

Close Document

Close the current document. If there are unsaved changed you will be asked if you
want to save

e following commands apply on 10.6 and earlier, or on later OS X releases with versions
support turned off

Save

Save the current document, to the existing file (if one exists) or SQLEditor will ask
you to choose a location to save

Save As...

Save the current document to a new location
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File Menu

Revert to Saved

Abandon any changes in the current document and revert the version that was last
saved
e following commands apply on 10.7 and later, with versions support enabled

Save a version

Save the current state of the document as a snapshot in the timeline

Duplicate

Create a copy of the current document, to allow saving as a separate document

Revert Document

Revert to a previous revision of the document

Export to File

Export the current document to a SQL text file (or database migration)
See also: Importing from a SQL file on page 47

Export to Database

Export the current document to a database, possibly updating an existing database
See also: Exporting to a database on page 43

Export Diff

Export a SQL diff to a file. e current document is compared against another
document or snapshot. You can choose which in the save panel

Export

If there are any export plugins installed, then they may appear here.
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Save as Image

Save the entire current document as an image.
See also: Save as Image on page 49

Document Options...

Displays the Document Options Window for the current document
See also: e Document Options Window on page 62

Page Setup...

Displays the standard Mac OS X page setup window.

Print

Displays the standard Mac OS X print sheet. SQLEditor adds a panel which offers
control over how the document is fitted to the paper

Edit Menu

Undo

Undo the last operation

Redo

Redo the last operation that was undone

Cut

Cut the current object from the document and place it on the clipboard

Copy

Copy the current object and place it on the clipboard
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Paste

Insert the contents of the clipboard into the document

Not everything can be inserted, watch the status window for errors

Delete

Remove the currently selected object(s) from the document

Select All

Select all objects in the document

Duplicate

Duplicate the currently select object(s)

Find

A submenuwith various find commands, only Find Object is valid for objects, it opens
the Find Object Panel

Spelling

e spelling submenu offers standard commands for spell checking, which are
available when editing text

Object Menu

Add Table

Add a new table to the document

Add Comment

Add a new comment to the document
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Add Field

Add a new field to the currently selected table.

If no table is selected, or if more than one table is selected, this option is
disabled

Add Index

Add a new Index to the currently selected table.

If no table is selected, or if more than one table is selected, this option is
disabled

Add Constraint

Add a new Constraint to the currently selected table.

If no table is selected, or if more than one table is selected, this option is
disabled

Add Foreign Key

Add a new Foreign Key object to the currently selected table.
Foreign key objects are distinct from field level foreign keys

If no table is selected, or if more than one table is selected, this option is
disabled

Add Canvas Area

Add a new Canvas Area to the document

Add View

Add a new View object the document
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Previous Object

Select the previous object in the document.

Next Object

Select the next object in the document.

Inspect Object

Opens the inspector and inspects the current object.

Arrange Objects

Arrange the objects in the document, attempting to remove overlaps and minimize
the space used

is may cause arrangements that aren’t optimal

Align Objects

e commands in this submenu align objects on the canvas to each other

Align Left Edges Aligns the selected objects so that the left edges are all aligned
to the left edge of the leftmost object.

AlignRightEdges Aligns the selected objects so that the right edges are all aligned
to the right edge of the rightmost object

Align Top Edges Aligns the selected objects so that the top edges are all aligned
to the top edge of the highest object

Align Bottom Edges Aligns the selected objects so that the bottom edges are all
aligned to the bottom edge of the lowest object
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AlignVerticalCenters is moves objects so that they are all aligned through their
center points in the vertical axis. e alignment point is chosen by averaging the
vertical center points.

Align Horizontal Centers is moves objects so that they are all aligned through
their center points in the horizontal axis. e alignment point is chosen by averaging
the horizontal center points.

Label

is submenu allows you to change the label of an object.

New Label with Selection Creates a new label, asking for a name and color, then
adds all of the currently selected objects to the new label

ViewMenu

e view menu contains commands to control the visual appearance of the current
document.
e settings used in new documents can be changed in the Defaults Preferences Panel
on page 69

Zoom

e Zoom menu allows you to increase or decrease the visible size of the objects. It
doesn’t make any changes to the objects themselves, just your view of them.

Zoom 100%, Zoom 75%, Zoom 50%, Zoom 25% ese commands zoom the
canvas to the specified zoom factor

ZoomArea is command displays a cross hair cusor which you use to drag out an
area on the canvas. e canvas zoom factor will then be set so that the entire zoom
area fits within the window

Zoom to fit Change the zoom factor so that all of the objects on the canvas fit in
the window without scrolling
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Zoom In Increase the zoom factor by 5%

ZoomOut Decrease the zoom factor by 5%

Show Page Boundaries

SQLEditor can draw a blue line where the approximate edge of the page will be if
the document is printed using the current printer settings

Show Field Types

Set whether the SQL type of fields is drawn.

Show Field Icons

Set whether the informational icons are drawn on fields.

Snap To Grid

Set whether table locations are constrained to the page grid.
is applies when dragging objects

Auto Size Tables

Set whether tables are automatically resized to accomodate their contents.
Resizing may occur when table or field options are changed in order to display all
required information and icons

Show All Objects

Set any objects previously hidden to be visible

Toggle Label Visibility

Make hidden labels (and their objects) to be visible, while making visible labels (and
their objects) hidden.
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WindowMenu

Show/Hide Inspector

is action will show or hide e Inspector Window (page 53).

Show/Hide Paleśe

is action will show or hide the e Object Palette (page 56).

Show/Hide Find Panel

is action will show or hide e Find Panel (page 57).

Show/Hide Status Panel

is action will show or hide e Status Panel (page 56).

Minimize

is action temporarily removes the current window from the screen and places a
icon representing it in the Dock. You can also perform this action by clicking the
orange Minimize button on any document window titlebar

Show/Hide Sidebar

is action will show or hide the sidebar

Bring All To Front

is action moves all open SQLEditor document windows in front of any other
application’s windows.

Bring Current To Front

is action moves the current document window to the front and selects it.
is allows you to switch focus between the inspector and the document window
using the keyboard
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Show/Hide Toolbar

is action shows or hides the document window toolbar. You can also perform
this action by clicking the oval toolbar control button at the top right corner of any
document window.

Customize Toolbar

is action will display the standard Mac OS X toolbar customization panel which
allows you to add, remove and rearrange the document toolbar.

Other Entries

e Window Menu will also list all currently open documents. You can choose an
entry to switch to that document.

Help Menu

SQLEditor Help

Display online help

Read me Ņle

Display the read me file that ships with SQLEditor

Release Notes

Display the SQLEditor change log

Send Suggestion

A shortcut for sending suggestions to the developers. is will either open a new
email message in your email program or display a web form. All suggestions are
gratefully received

SQLEditor Support (web)

Opens the SQLEditor support page in your web browser
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JDBC Driver Support (web)

Opens the SQLEditor JDBC driver web page in your web browser

Online Store (web)

Opens the SQLEditor online store in your web browser
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